Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P11-144 Not Starting
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera P11-144 Not Starting

 Post Reply Post Reply
Author
Message
pragmatist_m View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 21 Jan 2014
Location: Nigeria
Online Status: Offline
Points: 161
Post Options Post Options   Thanks (0) Thanks(0)   Quote pragmatist_m Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera P11-144 Not Starting
    Posted: 12 Jul 2017 at 11:45am
My Nissan primera P11-144 is not starting for two days now. 

The engine is SR20DE 2.0

The battery and kick starter are OK. We changed plugs and it keeps making starting/rolling noise but not starting. 

The only thing is that few days before it finally stopped to start, when parked for long or overnight and started it, there was a "tututu" sound which went away as I raised it. And I observed about two weeks ago that the smoke coming from the exhaust was peppering the eyes but that had stopped.

Please help.
Your car's problem may be solved if you don't give up.
Back to Top
p11primeragt View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar

Joined: 29 Jul 2011
Location: North east
Online Status: Offline
Points: 17992
Post Options Post Options   Thanks (0) Thanks(0)   Quote p11primeragt Quote  Post ReplyReply Direct Link To This Post Posted: 12 Jul 2017 at 10:07pm
Try some easy start in the intake to rule out a fuel problem. Does it spin faster than normal? If it's normal then it's likely that the compression is ok.
If you want the truth,ask my opinion.
Back to Top
p11primeragt View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar

Joined: 29 Jul 2011
Location: North east
Online Status: Offline
Points: 17992
Post Options Post Options   Thanks (0) Thanks(0)   Quote p11primeragt Quote  Post ReplyReply Direct Link To This Post Posted: 12 Jul 2017 at 10:09pm
Check make sure the plugs are firing.If not then check the distributor.
If you want the truth,ask my opinion.
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2017 Nissan Primera Owners Club. All rights reserved.