Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > New Members
  New Posts New Posts RSS Feed - Fans not working for heater / cooler?
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Fans not working for heater / cooler?

 Post Reply Post Reply Page  12>
Author
Message
Graeme 1 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 17 Sep 2011
Location: Oamaru New Zeal
Online Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Graeme 1 Quote  Post ReplyReply Direct Link To This Post Topic: Fans not working for heater / cooler?
    Posted: 17 Sep 2011 at 10:00am
Hi to the members of this forum, I have never been involved in a forum before so hope I do the right things.
I have recently bought a 2002 Primera saloon and the fans for the heater / cooler in the car have stopped working. I have checked all fuses and none appeared to be blown. Not sure what the next step is. I would think that there would be a resistor for the control of the fan speeds but can't find anything that looks like one. Was wondering if there was any one that has had this happen and what the fix would be. Tis a great car but this was a dissapointment. I am still trying to find a wiring diagram that I can follow through to try and find the bits.
Thanks to those for reading. Graeme.
Back to Top
Geordie View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar
Not in Estate

Joined: 27 Feb 2009
Location: Coffee Machine
Online Status: Offline
Points: 12142
Post Options Post Options   Thanks (0) Thanks(0)   Quote Geordie Quote  Post ReplyReply Direct Link To This Post Posted: 17 Sep 2011 at 10:08am
Hi, and welcome to NPOC.

2002 was a changeover year for the Primera's, so it would help if you could let us know what version you have....either P11-144 or P12.

Are the fans not working on any setting?
Car of the Month April 2010 (Black GT)
Car of the Month August 2012 (Red Wagon)
"You are a one man, used car industry, improvement system!!" - Tom (12/12/16)
Back to Top
norbert eggcup View Drop Down
NPOC Guest
NPOC Guest
Avatar
Swiss Tony

Joined: 06 Dec 2006
Location: in a civic
Online Status: Offline
Points: 4458
Post Options Post Options   Thanks (0) Thanks(0)   Quote norbert eggcup Quote  Post ReplyReply Direct Link To This Post Posted: 18 Sep 2011 at 1:15am
taken from the invisible "how to..." section
http://www.npoc.co.uk/forum/forum_posts.asp?TID=12795&PID=185415&title=p12-fan-speed-control-module-diy-repair#185415 

check and change the pollen filter while your at it
the spaceship and the P12
Back to Top
Graeme 1 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 17 Sep 2011
Location: Oamaru New Zeal
Online Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Graeme 1 Quote  Post ReplyReply Direct Link To This Post Posted: 18 Sep 2011 at 1:24am
Well that was a silly mistake on my part!!! My car is a p12. The fans do not work at all. The airconditioner is switching on; the radiator fans switch on but we have no fans internally. We have only had it 3 months so it is a bit of a let down.
 
Regards Graeme.
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 13754
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 18 Sep 2011 at 1:02pm
Welcome to the forumHandshake
It is not the end of the world it is a cheap fix. The fault is sometimes attributed to a dirty pollen filter and hence why it is mentioned aboveThumbs Up
Back to Top
Graeme 1 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 17 Sep 2011
Location: Oamaru New Zeal
Online Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Graeme 1 Quote  Post ReplyReply Direct Link To This Post Posted: 19 Sep 2011 at 9:09pm
Thanks to those that have given me the the good info. I have priced a new part and shock!!!!! they were wanting just over $500-00 N.Z. Priced the part and it was $6-60N.Z. Next job to repair myself and be smileing again. I will also check the pollen filter. This has been the best meeting of people I have had for many years. Look forward to keeping in touch in the future.
Regards Graeme.
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 13754
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 19 Sep 2011 at 9:45pm
Good result. good luck with the repair, just give England a supporting cheer down there thoughLOL
Back to Top
Graeme 1 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 17 Sep 2011
Location: Oamaru New Zeal
Online Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Graeme 1 Quote  Post ReplyReply Direct Link To This Post Posted: 20 Sep 2011 at 10:38am
Hi Geordie, I have now repaired the control unit and at no cost as it appears that there was just a dry joint. All the help and advise I have received from this forum has been absolutely great. We now have a great heater in a great car.
Regards Graeme.
Back to Top
ragt20 View Drop Down
Admin Group
Admin Group

Swiss Tony

Joined: 02 May 2003
Location: Other
Online Status: Offline
Points: 69135
Post Options Post Options   Thanks (0) Thanks(0)   Quote ragt20 Quote  Post ReplyReply Direct Link To This Post Posted: 20 Sep 2011 at 8:33pm
cool to hear you got the problem sorted and got some heat, though would have thought in a place like NZ, you would prolly need the AC working more..:)
FAO : Laurens, I am not Shaun.
FAO : bavs83, I am not Tan.

Back to Top
Graeme 1 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 17 Sep 2011
Location: Oamaru New Zeal
Online Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Graeme 1 Quote  Post ReplyReply Direct Link To This Post Posted: 30 Sep 2011 at 10:16pm
Hi all this is the P12 from way down under again. I am being hopefull here that there may be a way of getting the navigation system working in our car. As we get imports in from Japan I am looking to see if there is any guidance from someone who to contact or a way to get it working. Seems a shame that this great car now has the good stuff but it will not work down here in New Zealand. Been trying to find information about this here but to no avail. Hope to here from someone that this is an easy fix just like the fans were.. I am all eager to have the car and all its facilitys working.
Regards Graeme.
 
Back to Top
 Post Reply Post Reply Page  12>

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2019 Nissan Primera Owners Club. All rights reserved.