Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > New Members
  New Posts New Posts RSS Feed - Ignition problem P12
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Ignition problem P12

 Post Reply Post Reply
Author
Message
Barzakh View Drop Down
NPOC Guest
NPOC Guest


Joined: 17 Dec 2016
Location: Finland
Online Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Barzakh Quote  Post ReplyReply Direct Link To This Post Topic: Ignition problem P12
    Posted: 13 Aug 2019 at 5:52pm
Hi all,

I'm from Finland, my car
NISSAN PRIMERA Hatchback (P12) 1.8 2004.

Always had an issue with starting the car. Now just got worse...

List of things done:
Battery changed, camshaft sensor changed, plugs changed, condenser ign. changed. Final try bought some CRC-spray.

All seemed help a little/awhile but problem come again. Car always starts if block heater on. Also it started with cables. When it doesn't start, follow occur; the car starts and after 2-3 seconds "suffocates" and will not start again. It kind of starts for half a second but shutsdown.

Weekend I will try fix it. Change the crankshaft sensor, change the airmassmeter (?) And buy one ignition coil, switch it around an see if any changes.

Any other ideas and should I not do any of the mentioned things?
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 13810
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 13 Aug 2019 at 6:25pm

Check the battery earth leads to the chassis and transmission particularly the latter making sure they have good connection and no breaks

 
Also, it sounds strange but check the rubber cap on the headlight is not loose and fouling the air intake
Back to Top
pianoprimera View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 29 Jun 2019
Location: Staffordshire
Online Status: Offline
Points: 16
Post Options Post Options   Thanks (0) Thanks(0)   Quote pianoprimera Quote  Post ReplyReply Direct Link To This Post Posted: 15 Aug 2019 at 10:18am
I wish I could give a positive answer to this. I know Finland is considerably colder than Britain in winter, but we've arrived back at Manchester Airport to find the Primera white with frost and ice. Yet it starts first turn. They should be AMAZING starters! My first port of call would be the MAF (mass-air-flow) sensor, to first try cleaning with electrical contact spray (look up YouTube Scotty Kilmer on how to do this) and then try an Ebay replacement if the spray does not work. Whilst the MAF sensor is off check the bellowed rubber piping is not blocked too; and clean out the throttle body - check it's not sticking. (PS: you must have already checked the air filter is not blocked?)
Back to Top
Barzakh View Drop Down
NPOC Guest
NPOC Guest


Joined: 17 Dec 2016
Location: Finland
Online Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Barzakh Quote  Post ReplyReply Direct Link To This Post Posted: 18 Aug 2019 at 2:29pm
Hi, thank you for all good advices, I will surtainly look to those. Meanwhile, in lack of money, I didn't buy any new parts but tried something out. While I was removing the ignition coils, 2 of the crews broke! That was odd, how fragile they were. Anyway, I swapped them around by putting 1st to 2nd, 2nd->3rd, 3rd->4th and 4th to 1st. Seems more starting problems, doesn't stop while driving and no shut off while starting up. Let's see, will this last or just a coincidence.
Back to Top
Barzakh View Drop Down
NPOC Guest
NPOC Guest


Joined: 17 Dec 2016
Location: Finland
Online Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Barzakh Quote  Post ReplyReply Direct Link To This Post Posted: 18 Aug 2019 at 2:30pm
Sorry for the typo; I meant *no more starting problems.
Back to Top
pianoprimera View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 29 Jun 2019
Location: Staffordshire
Online Status: Offline
Points: 16
Post Options Post Options   Thanks (0) Thanks(0)   Quote pianoprimera Quote  Post ReplyReply Direct Link To This Post Posted: 19 Aug 2019 at 9:33am
Good! Of course the P12 was created as Nissan became under the control of Renault. I bought mine simply because of Chain Drive camshaft, and the huge amount of space (Estate) and multi airbags. It's never really occurred to me whether the Renault ignitions coils problems across practically the whole range may have been passed onto the P12. You did take out the plugs and check them I presume for oil fouling and cracked insulators?

Sadly the days of Datsun / Nissan cars being superb reliable machines are now gone. Renault killed off stone dead this reputation . . .
Back to Top
Barzakh View Drop Down
NPOC Guest
NPOC Guest


Joined: 17 Dec 2016
Location: Finland
Online Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Barzakh Quote  Post ReplyReply Direct Link To This Post Posted: Today at 5:41pm
I did change the plugs. I'm still going to change the MAF and Crankshaft sensor, I'm pretty sure they are not 100% ok, even I got over the worst problems. I bought this one because the space in back :) its an old car, I understand it having its problems.. About 270tkm driven. I will let you know next week how changing the MAF affected.
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2019 Nissan Primera Owners Club. All rights reserved.