Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > New Members
  New Posts New Posts RSS Feed - Nissan Primera 1.8 S -Car lacks power
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera 1.8 S -Car lacks power

 Post Reply Post Reply
Author
Message
DARWIN1 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 21 Sep 2011
Online Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote DARWIN1 Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera 1.8 S -Car lacks power
    Posted: 21 Sep 2011 at 11:36am
Hello,

I am  a new member and I need a bit of help. Whilst I was driving the car on motorway I noticed that engine is  lacking power when acceleration is required. Car is a Nissan Primera 1.8 s (2004)

Any thoughs or advise on this?

Many Thanks

   Darwin1Ermm
Back to Top
ernehale View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 30 Mar 2011
Location: Notts
Online Status: Offline
Points: 665
Post Options Post Options   Thanks (0) Thanks(0)   Quote ernehale Quote  Post ReplyReply Direct Link To This Post Posted: 21 Sep 2011 at 12:18pm
Hello and welcome to the club.Handshake
 
Is it just a loss of power, are there any other symptoms? Is the management information light (MIL)on? If it is get the codes read.
Have you looked at all the usual suspects plugs, leads,  filter? If you've done that it could be the MAF. Remove it very carefully and carefully clean it with spray carb cleaner don't touch its very fragile being a small heated element, just let the spray do its work, that sometimes works and is a lot cheaper if it does than a replacement.  All the best I have no doubt there will be more posts to your thread. If you get a cure to the problem let us know what it was, if not stick another post on.
Back to Top
DARWIN1 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 21 Sep 2011
Online Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote DARWIN1 Quote  Post ReplyReply Direct Link To This Post Posted: 21 Sep 2011 at 1:56pm
Hello Ernehale,

Thanks for replying with your advise. There are no lights indicating malfunction but I will check plugs,leads and filter. 

I will see how it fares after that.

Cheers

Darwin1
Back to Top
crazy taxi View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 06 Jun 2004
Location: Salford
Online Status: Offline
Points: 9014
Post Options Post Options   Thanks (0) Thanks(0)   Quote crazy taxi Quote  Post ReplyReply Direct Link To This Post Posted: 22 Sep 2011 at 9:58pm
Is the idle uneven?
Old enough to know better, too old to change
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2018 Nissan Primera Owners Club. All rights reserved.