Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - nissan primera 2003 p12 2.2 dci, limp mode
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

nissan primera 2003 p12 2.2 dci, limp mode

 Post Reply Post Reply Page  12>
Author
Message
chripsy View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 19 Mar 2018
Location: bedworth
Online Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote chripsy Quote  Post ReplyReply Direct Link To This Post Topic: nissan primera 2003 p12 2.2 dci, limp mode
    Posted: 19 Mar 2018 at 5:33pm
hi guys i need some advice.

the primera we have just acquired keeps going into a limp mode, 90% of the time without the engine light coming on or the fault message coming up on the screen.

i have been in touch with west way nissan in coventry and they quoted 580 to supply and fit a new one. i generally only work on bikes or pre ecu cars so im not sure if this is a good or bad quote.

also the radio dosnt work i have a green screen with the word secure come up. when you press the radio button nothing happens no screen change or beeps.

any help would be greatly appreciated

ps sorry for not putting nissan primera in original post i assumed that the year,model number and engine type would suffice


chris
Back to Top
p11primeragt View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar

Joined: 29 Jul 2011
Location: North east
Online Status: Offline
Points: 18487
Post Options Post Options   Thanks (0) Thanks(0)   Quote p11primeragt Quote  Post ReplyReply Direct Link To This Post Posted: 19 Mar 2018 at 5:50pm
Idle from cold start smooth?
the price is forgotten long after the quality remains
Back to Top
chripsy View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 19 Mar 2018
Location: bedworth
Online Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote chripsy Quote  Post ReplyReply Direct Link To This Post Posted: 19 Mar 2018 at 6:34pm
Sometimes it idles fine from cold, it sits around 600-700 room. Every now and again it's hunting jumping between 400-800 rpm
Back to Top
chripsy View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 19 Mar 2018
Location: bedworth
Online Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote chripsy Quote  Post ReplyReply Direct Link To This Post Posted: 19 Mar 2018 at 7:52pm
i forgot to mention, i have had a diagnostic check done and the only fault code that is persistent is p0089 
Back to Top
p11primeragt View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar

Joined: 29 Jul 2011
Location: North east
Online Status: Offline
Points: 18487
Post Options Post Options   Thanks (0) Thanks(0)   Quote p11primeragt Quote  Post ReplyReply Direct Link To This Post Posted: 19 Mar 2018 at 10:00pm
You need a scv.
the price is forgotten long after the quality remains
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 13365
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 19 Mar 2018 at 10:08pm
Yes classic hunting symptom for a duff SVC, you could try this first

http://www.npoc.co.uk/forum/p12-all-engines-read-reset-ecu-fuel-pump_topic54932.html

it has worked for some folk.

As for the green secure, it means the radio is not communicating with the IMMU security, so either someone has swapped the unit out or it is faulty

Back to Top
chripsy View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 19 Mar 2018
Location: bedworth
Online Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote chripsy Quote  Post ReplyReply Direct Link To This Post Posted: 19 Mar 2018 at 10:55pm
the previous owner is known to us and when he had the car it never got used. the battery was boosted a few times in his ownership and spent the majority of its time flat. the reason we got the car was the key had disappeared so we had to get a new one cut and programed. could that be the reason of the radio messing up?

thanks for the replies so far, this is why i stick to pre ecu cars
Back to Top
chripsy View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 19 Mar 2018
Location: bedworth
Online Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote chripsy Quote  Post ReplyReply Direct Link To This Post Posted: 19 Mar 2018 at 10:59pm
in regards to the radio, the car is acting like it does not even exist, when you press the buttons there is no change to screen or any sounds at all, after a couple of mins the screen changes to black with green box saying secure, is this normal?

Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 13365
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 20 Mar 2018 at 6:33am
Were you able to ask the owner when the radio started to display the Secure message. The AV unit does not normally lose the code when the battery is disconnected, however if as you say it has been flat for long periods of time particularly freezing temps it is just possible I suppose it has rest. In which case it will need recoding to your car just like your key. The other possibility other than lost key and broken unit is the NATS amplifier, a ring around the ignition barrel secured by a single screw (once you have the cow off) need removing carefully dusted off and put back.Thumbs Up
Back to Top
chripsy View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 19 Mar 2018
Location: bedworth
Online Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote chripsy Quote  Post ReplyReply Direct Link To This Post Posted: 20 Mar 2018 at 11:10am
can you guys recommend any firm in the midlands who could try to recode the radio, west way nissan in coventry have pretty much said they wont get involved, i need to get this sorted otherwise im pretty much much living on the couch, as im being reminded daily it was my decision  to get this car

in regards to the scv i am going to order a new one, i take it i have to get both part numbers, pump and valve? where would be the best place to order one from?




Back to Top
 Post Reply Post Reply Page  12>

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2018 Nissan Primera Owners Club. All rights reserved.