Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P11 144 crank position sensor
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Click HERE to check out the latest awesome Club Video, courtesy of NPOC Member edk_N16 - Thanks Ed!


Nissan Primera P11 144 crank position sensor

 Post Reply Post Reply
Author
Message
cestrian87 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 02 Apr 2010
Location: chester
Online Status: Offline
Points: 35
Post Options Post Options   Thanks (0) Thanks(0)   Quote cestrian87 Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera P11 144 crank position sensor
    Posted: 23 Jun 2010 at 10:31pm
Hello there. sad to say but im having trouble with my prim still.as stated its a 144 its the 1.6 qg16de i keep getting fault code from my crank position sensor.
so whentto get one from the scrappy seems that everyone wnts one as every nissan with the same engine all had them missing acceptone.so gets it of puts it on and itsdoing the exact same thing.turns out its a nissan only part 76 quid nissan only part to be precise.Angry
 
so i then find out from nissan that the cam sensor is the exact same part.so i put the cam sensor on the crank and visa versa.its better but still no look yet im nt getting a fault code for my cam even though its suppose to be a duff sensor.
 
i was wondering do u think that there may be summit rng witht hte crank like the notches it uses mite be worn or one mite be missing or summit.or could it be a case i need fresh oil to get rid of a clog or summit.help would be grand as im using it for work now and its using a fair chink of fuel.
conquer the mind, the rest will follow.
Back to Top
yogi View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 11 Mar 2007
Online Status: Offline
Points: 6280
Post Options Post Options   Thanks (0) Thanks(0)   Quote yogi Quote  Post ReplyReply Direct Link To This Post Posted: 23 Jun 2010 at 10:35pm
Sounds like a stretched timing chain fella had the same fault with my QG18DE only way to find out is to remove the cam cover and have a look at the chain if it's like an elastic band the it will need a replacement kit.
 
BTW I went down the cam/crank sensor route the hard way and nothing was wrong with them Ouch
Previous:P11-144 Qg18
Current: lexus Is
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2014 Nissan Primera Owners Club. All rights reserved.