Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P11 2.0TD fuel return valve
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera P11 2.0TD fuel return valve

 Post Reply Post Reply
Author
Message
Astral07 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 24 Jan 2013
Location: Croatia
Online Status: Offline
Points: 155
Post Options Post Options   Thanks (0) Thanks(0)   Quote Astral07 Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera P11 2.0TD fuel return valve
    Posted: 27 Jul 2018 at 11:29am
Hi everyone,

New issue with my Primera, if i park it uphil, and leave it for a few hours, it will be very hard to start the engine. I need to add some pedal gas when starting it.

If however, I park nose down (downhill), there is no problem.

Even a slight uphil is a problem (almost horizontal).

Any idea what the issue might be? Is there a return valve that might have gone bad?
Back to Top
Astral07 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 24 Jan 2013
Location: Croatia
Online Status: Offline
Points: 155
Post Options Post Options   Thanks (0) Thanks(0)   Quote Astral07 Quote  Post ReplyReply Direct Link To This Post Posted: 31 Jul 2018 at 8:21am
Can someone help me find a schematic of the fuel system so i can see what are the components and how it works?
Back to Top
d60_tag View Drop Down
NPOC Guest
NPOC Guest


Joined: 18 Jul 2015
Online Status: Offline
Points: 519
Post Options Post Options   Thanks (0) Thanks(0)   Quote d60_tag Quote  Post ReplyReply Direct Link To This Post Posted: 18 Aug 2018 at 12:18pm
Fuel filter possibly slightly blocked?

On my Primera 1.6 petrol, the fuel supply line has actually developed a small leak, which lay undetected by me for a while, even though I could smell fuel in the engine bay. Then a month or so later, the hose actually burst and seriously split.
I figured the fuel system had got too pressurised, probably caused by a blocked fuel filter, which was putting extra stress/ load on the feed and pressure, causing the burst hose. I replaced the hose and fuel filter and been okay ever since for 6months. Filter had only been on there a year or two maximum but reckon it had become blocked causing the extra pressure trying to feed through but not being able to cleanly.

Seen many cars suffer with blocked fuel filters and they often have different consequences, some get starved underload but are okay upto 40mph but not at 50mph or above. Some hesitate on acceleration badly, even from standstill. Others possibly have starting issues etc, others like mine may split hoses etc.
Defo worth changing the filter if you not done it recently for what they cost, to eliminate that as being the problem.

Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2018 Nissan Primera Owners Club. All rights reserved.