Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - nissan primera p11 engine problems
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

nissan primera p11 engine problems

 Post Reply Post Reply Page  12>
Author
Message
deano501 View Drop Down
NPOC Guest
NPOC Guest


Joined: 29 Aug 2011
Online Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote deano501 Quote  Post ReplyReply Direct Link To This Post Topic: nissan primera p11 engine problems
    Posted: 07 Feb 2015 at 9:44am
my 1.8 p11 2000 model starts and runs fine until after about 3 miles then cuts out and wont restart until its been left for about half an hour.. ive changed the coil packs but nothing has changed. could this be fuel related or is there another common fault that could be causing this.. its a petrol model.. thanks deano 501
Back to Top
deano501 View Drop Down
NPOC Guest
NPOC Guest


Joined: 29 Aug 2011
Online Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote deano501 Quote  Post ReplyReply Direct Link To This Post Posted: 07 Feb 2015 at 12:54pm
i have now changed the fuel filter and still the same thing is happening.. rather stuck now any ideas... thanks deano501
Back to Top
p11primeragt View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar

Joined: 29 Jul 2011
Location: North east
Online Status: Offline
Points: 18510
Post Options Post Options   Thanks (0) Thanks(0)   Quote p11primeragt Quote  Post ReplyReply Direct Link To This Post Posted: 07 Feb 2015 at 5:34pm
Have you got the engine management light on?

Sounds more like faulty cam or crank sensor.
Back to Top
deano501 View Drop Down
NPOC Guest
NPOC Guest


Joined: 29 Aug 2011
Online Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote deano501 Quote  Post ReplyReply Direct Link To This Post Posted: 07 Feb 2015 at 6:28pm
yes the light is on on the dash..
are the cam and crank sensors an easy diy fix or is it a trip to the garage.
Back to Top
p11primeragt View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar

Joined: 29 Jul 2011
Location: North east
Online Status: Offline
Points: 18510
Post Options Post Options   Thanks (0) Thanks(0)   Quote p11primeragt Quote  Post ReplyReply Direct Link To This Post Posted: 07 Feb 2015 at 7:34pm
Both sensors are just plug and play.

Best getting a cheap diagnostic scanner which plugs into the diagnostic socket,it will tell you the fault code.Therefore no guessing. 
Back to Top
TheStigP11GT View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 10 May 2003
Location: Dunfermline
Online Status: Offline
Points: 12640
Post Options Post Options   Thanks (0) Thanks(0)   Quote TheStigP11GT Quote  Post ReplyReply Direct Link To This Post Posted: 07 Feb 2015 at 11:48pm
The Bluetooth elm scanner works well for Android connectivity to get EML codes. 
---Current Cars---
Primera GT - SR20VE.N1 / Qashqai 1.5 N-Tec K9K / Pulsar 1.5 N-Tec K9K
http://www.neovvl.com
Back to Top
deano501 View Drop Down
NPOC Guest
NPOC Guest


Joined: 29 Aug 2011
Online Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote deano501 Quote  Post ReplyReply Direct Link To This Post Posted: 08 Feb 2015 at 9:37am
Thanks are the sensors the same as when looking up both they look indetical to each other.
Back to Top
imckay View Drop Down
NPOC Member
NPOC Member


Joined: 11 Mar 2007
Location: Manchester
Online Status: Offline
Points: 3153
Post Options Post Options   Thanks (0) Thanks(0)   Quote imckay Quote  Post ReplyReply Direct Link To This Post Posted: 08 Feb 2015 at 10:02am
You can run a self diagnostic to get the fault codes.
You just need a thin piece of wire.
Diagnostic port is below the fuse box to the right of the steering wheel.

http://www.npoc.co.uk/forum/p11144-diagnostic-check-clear-and-codes_topic8946.html

Or get an OBD2 Code reader.


Back to Top
redshark1 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 31 Mar 2007
Location: Yorkshire (West)
Online Status: Offline
Points: 1827
Post Options Post Options   Thanks (0) Thanks(0)   Quote redshark1 Quote  Post ReplyReply Direct Link To This Post Posted: 08 Feb 2015 at 6:44pm
Its been said on here the sensors are the same. Possibly the wire length could be different but not sure.
See my Nissan Primera P11-144 common faults and fixes guide:
Back to Top
deano501 View Drop Down
NPOC Guest
NPOC Guest


Joined: 29 Aug 2011
Online Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote deano501 Quote  Post ReplyReply Direct Link To This Post Posted: 09 Feb 2015 at 6:53pm
THANKS GUYS FOR YOUR HELP. CHANGED THE CAM SENSOR THIS AFTERNOON AND EVERYTHING SEEMS TO BE FINE NOW... IS IT WORTH DOING THE CRANK SENSOR ASWELL JUST TO BE ON THE SAFE SIDE...    DOES THE ENGINE LIGHT NEED RESETTING OR WILL IT GO OUT BY ITSELF? MANY THANKS ONCE AGAIN FOR YOUR HELP.. DEANO501
Back to Top
 Post Reply Post Reply Page  12>

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2018 Nissan Primera Owners Club. All rights reserved.