Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P11 none start when hot
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera P11 none start when hot

 Post Reply Post Reply
Author
Message
s.r.pete View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 31 Oct 2017
Location: North Essex
Online Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote s.r.pete Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera P11 none start when hot
    Posted: 02 Nov 2017 at 8:56pm
 Hi all, 2nd time of trying, just rejoined the club
after many moons, as i've just bought a 1.6 P11
off an old chap, 1997 1.6 Precicion, only done
28,000 miles, very tidy and clean, however i have
one problem she won't start when hot, you have
to leave it for a good 45 mins. before she will go
again, any ideas what could be the problem. Ouch

pdg
Back to Top
p11primeragt View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar

Joined: 29 Jul 2011
Location: North east
Online Status: Offline
Points: 18233
Post Options Post Options   Thanks (0) Thanks(0)   Quote p11primeragt Quote  Post ReplyReply Direct Link To This Post Posted: 02 Nov 2017 at 9:02pm
Could be fuel pump/relay for it.

Had a bad one recently,would still start but cut out after a few secs when warm/hot,let it cool down and it would run for a lot longer.

Also check for spark when hot,could be a failing distributor/crank sensor which not unheard of on a ga16de engine.
Back to Top
s.r.pete View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 31 Oct 2017
Location: North Essex
Online Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote s.r.pete Quote  Post ReplyReply Direct Link To This Post Posted: 03 Nov 2017 at 9:21pm
 ok thanks will check them out.
pdg
Back to Top
s.r.pete View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 31 Oct 2017
Location: North Essex
Online Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote s.r.pete Quote  Post ReplyReply Direct Link To This Post Posted: 05 Nov 2017 at 9:25pm
 hi again, thanks for your help, got it sorted, not so bad
after all, interesting little thing, wait for it !!
the little sprung loaded terminal on the inside of the
Dissy cap, the one that sits on top of the rotor arm
was missing, only a hole there, how i was getting a
spark i don't no, guess after i managed to get it started
it must have been arcing over, anyway all sorted,
many thanks, starts on 1/4 of a turn now Smile
pdg
Back to Top
p11primeragt View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar

Joined: 29 Jul 2011
Location: North east
Online Status: Offline
Points: 18233
Post Options Post Options   Thanks (0) Thanks(0)   Quote p11primeragt Quote  Post ReplyReply Direct Link To This Post Posted: 05 Nov 2017 at 9:50pm
Good to hear
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2017 Nissan Primera Owners Club. All rights reserved.