Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P12 2.2 dCi momentary power loss
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera P12 2.2 dCi momentary power loss

 Post Reply Post Reply
Author
Message
Paintitblack View Drop Down
NPOC Guest
NPOC Guest


Joined: 22 Mar 2016
Location: France
Online Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Paintitblack Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera P12 2.2 dCi momentary power loss
    Posted: 21 Jan 2018 at 1:08pm
A very stormy day yesterday and I was driving along the motorway at about 110km/h with cruise control when I felt a momentary deceleration. I thought that it was caused by a particularly strong gust. However it happened again a few moments later and then again until there was a total loss of power. I pulled over and waited ten seconds before restarting the engine and everything was fine for a few minutes until the issue started again. The engine warning light didn't come on.

Any ideas as to the cause?
Back to Top
p11primeragt View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar

Joined: 29 Jul 2011
Location: North east
Online Status: Offline
Points: 18415
Post Options Post Options   Thanks (0) Thanks(0)   Quote p11primeragt Quote  Post ReplyReply Direct Link To This Post Posted: 21 Jan 2018 at 2:37pm
Common faults are scv and turbos.Does it idle nicely from cold? Or is it lumpy?
the price is forgotten long after the quality remains
Back to Top
Paintitblack View Drop Down
NPOC Guest
NPOC Guest


Joined: 22 Mar 2016
Location: France
Online Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Paintitblack Quote  Post ReplyReply Direct Link To This Post Posted: 21 Jan 2018 at 3:21pm
Runs perfectly from cold. Not at all lumpy. Apart from the recent hesitation and then total loss of power it runs perfectly. The turbo was changed 40,000 miles ago and apart from a sticking operating rod which has been fixed there have been no other issues.
Back to Top
essNchill View Drop Down
Admin Group
Admin Group
Avatar
Nissyen Gaius Fluff

Joined: 05 Feb 2003
Location: Hampshire
Online Status: Online
Points: 61715
Post Options Post Options   Thanks (0) Thanks(0)   Quote essNchill Quote  Post ReplyReply Direct Link To This Post Posted: 21 Jan 2018 at 6:56pm
Just to check - This isn't happening when you have the indicators on (either side) as your're driving?
Back to Top
Paintitblack View Drop Down
NPOC Guest
NPOC Guest


Joined: 22 Mar 2016
Location: France
Online Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Paintitblack Quote  Post ReplyReply Direct Link To This Post Posted: 21 Jan 2018 at 8:02pm
No. Are you thinking of the famous faulty earth?
Back to Top
essNchill View Drop Down
Admin Group
Admin Group
Avatar
Nissyen Gaius Fluff

Joined: 05 Feb 2003
Location: Hampshire
Online Status: Online
Points: 61715
Post Options Post Options   Thanks (0) Thanks(0)   Quote essNchill Quote  Post ReplyReply Direct Link To This Post Posted: 21 Jan 2018 at 8:46pm
Yep - But looks like you've ruled this one out here :)
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 13256
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 21 Jan 2018 at 9:38pm
Could be one of the two battery earth leads , check for breaks and connection to chassis and transmission . When was the furl filter last changed? Checks for breaks, splits or fuel leakage on fuel lines
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2018 Nissan Primera Owners Club. All rights reserved.