Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera p12 cvt transmission
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera p12 cvt transmission

 Post Reply Post Reply
Author
Message
garvinni View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 16 Oct 2013
Location: trinidad
Online Status: Offline
Points: 31
Post Options Post Options   Thanks (0) Thanks(0)   Quote garvinni Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera p12 cvt transmission
    Posted: 08 Mar 2019 at 11:28am
Good day everyone. I have a nissan primera p12 with the qr20 engine coupled with a cvt. It's a 2003 model made in japan. The problem am having is when the car is parked overnight or for most of the day, when I start and select drive, I noticed the rpm doesn't drop right of way and when it does, the car doesn't move. The rpm will rise. After a few seconds the car will move and behave normally. When I select reverse, no problem.
Can anyone tell me what might to be problem? I brought this car used just under 75000 kms and currently doing just over 365000 kms. Since I had it, the cvt has not been replaced and I changed the fluid every year.
Back to Top
roy.2 View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar

Joined: 23 Jan 2010
Location: Nr Bourne Lincs
Online Status: Offline
Points: 3272
Post Options Post Options   Thanks (0) Thanks(0)   Quote roy.2 Quote  Post ReplyReply Direct Link To This Post Posted: 08 Mar 2019 at 5:00pm
Hi Garvin. I would start with checking the transmission fluid is at the right level. Thumbs Up
Roy
Back to Top
garvinni View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 16 Oct 2013
Location: trinidad
Online Status: Offline
Points: 31
Post Options Post Options   Thanks (0) Thanks(0)   Quote garvinni Quote  Post ReplyReply Direct Link To This Post Posted: 09 Mar 2019 at 1:10am
I checked that already. It's fine. I don't think this is important but I changed my fluid from ns-1 to ns-2 about 3 years ago because i wasn't getting ns-1.
Back to Top
imckay View Drop Down
NPOC Member
NPOC Member


Joined: 11 Mar 2007
Location: Manchester
Online Status: Offline
Points: 3244
Post Options Post Options   Thanks (0) Thanks(0)   Quote imckay Quote  Post ReplyReply Direct Link To This Post Posted: 09 Mar 2019 at 9:20am
I don't think NS-2 will be causing the problem.
There are occasionally people that use standard Auto Fluid and have problems very quickly.

From
https://berkeleystandard.com/car-transmission/warning-signs-issues-cvt-transmission/

Another classic sign of a CVT transmission malfunction is a noticeable hesitation for the transmission of the car to engage a gear when you put the gear shifter in “D” or “R.” Issues like low transmission fluid, a loose belt, or a failing clutch pack of an internal transmission seal can cause the delay in gear engagement.

Since Reverse is OK I guess it must be something to do with one of the Components for Forward Drive.

There may be some info/help here. Russia have Japanese Import Primeras
Google Translate to English


365K KM (227K Miles) is quite impressive.
It may not be worth fixing (or just living with the fault) but I don't know the used Car Market in Trinidad.
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2019 Nissan Primera Owners Club. All rights reserved.