Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - nissan primera p12 dci no power
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

nissan primera p12 dci no power

 Post Reply Post Reply Page  12>
Author
Message
weechicken09 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 08 Apr 2015
Location: derry
Online Status: Offline
Points: 137
Post Options Post Options   Thanks (0) Thanks(0)   Quote weechicken09 Quote  Post ReplyReply Direct Link To This Post Topic: nissan primera p12 dci no power
    Posted: 09 Jul 2015 at 8:53pm
hi all, I recentely posted a question about my 05 p12 dci not having any power in low gears and black smoke under load but got no answers, so I disconnected the MAF and it was the same but with less power, so then tried the EGR disconnected and it made no difference at all just drove the same, so I said f... it, rang Nissan booked it for a diagnostic test and was in today, report shows code p0404 egr fault, so they told me if I wanted to fix it they would wave the diag fee, so new egr and fuel filter £328.00 and I said right go ahead do it, cant wait to the morning now to see if that's the problem, I had the old egr cleaned not long ago but now im thinking it must not have been working at all,,,the car was off the road for 4 years so mabe that's why ?,,,,,will post tomorrow and let all know so for future nohow,,,,
Back to Top
weechicken09 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 08 Apr 2015
Location: derry
Online Status: Offline
Points: 137
Post Options Post Options   Thanks (0) Thanks(0)   Quote weechicken09 Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jul 2015 at 8:22am
well no difference after new EGR valve and fuel filter changed by Nissan at over £300 and no fault codes on their computer, the black smoke has virtualy gone when pedal down but still no power until turbo kicks in, im wondering is it the turbo, Nissan haven't a clue whats wrong and nibody on here does either, thers a terrible lag from ist gear to 2nd and to 3rd until the turbo kicks in, and even then no great power, well not 136 bhp,,,im lost now and nobody seems to know anything ??????
Back to Top
PrimeraPhill View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar

Joined: 07 Jan 2015
Location: Corsham
Online Status: Offline
Points: 1326
Post Options Post Options   Thanks (0) Thanks(0)   Quote PrimeraPhill Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jul 2015 at 8:40am
Ahhh that's a shame mate, u spent all the cash on what Nissan said was the issue, and it's still there.

I don't know a lot about diesels or the p12 model you have so good luck with the getting it fixed etc.

How long have you had the car? I assume it never used to feel like it does now?

Reason I ask, is when I had the 1.8 petrol, my mate had a 2.2 turbo diesel, but I would always smoke him on the lights, as diesels are just generally slower at pulling away. Not saying yours is just slow, just saying maybe it's how it was built?
MOTM APRIL 2016

PINK Primera GT
Back to Top
weechicken09 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 08 Apr 2015
Location: derry
Online Status: Offline
Points: 137
Post Options Post Options   Thanks (0) Thanks(0)   Quote weechicken09 Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jul 2015 at 8:44am
Its been like this since the new SCV was done on the pump,, i bought the car and it was in limp mode but it was lying up fot 4 years
Back to Top
Mukus View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 11 Jul 2015
Location: Sidmouth
Online Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Mukus Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jul 2015 at 9:35am
Hi guys. First time pleas forgive me about my English language skill.

So. I have Nissan primera 2.2 dci and now I got problem.
I'm not sure about the parts name is right or no. From the inlet manifold come rubber hose to the turbo pipe and this hose has split. Is a very short pipe on both end have different size.. I couldn't find on ebay or in the scrap yard. Do you know where can I find. or just I searching with wrong name.....

Thanks for help.

Sincerely Mukus
Back to Top
Mukus View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 11 Jul 2015
Location: Sidmouth
Online Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Mukus Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jul 2015 at 9:37am
Check the hose from the inlet manifold. I had same problem and that hose was split....
Back to Top
weechicken09 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 08 Apr 2015
Location: derry
Online Status: Offline
Points: 137
Post Options Post Options   Thanks (0) Thanks(0)   Quote weechicken09 Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jul 2015 at 9:46am
Already did no splits or no leaks
Back to Top
Mukus View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 11 Jul 2015
Location: Sidmouth
Online Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Mukus Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jul 2015 at 9:56am
Well I'm not sure but if the egr valve its fine and there is no leak on the air system, I can tell you maybe is some injection problem.You have black smoke when you try accelerate on low gear? Anyway deffinetly is not the turbo problem. 

Back to Top
weechicken09 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 08 Apr 2015
Location: derry
Online Status: Offline
Points: 137
Post Options Post Options   Thanks (0) Thanks(0)   Quote weechicken09 Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jul 2015 at 10:15am
No the turbo kicks in ok, you can feel it, its as if something was hding me back like a big elastic band, and no calipers sticking its just not geting the power it should have ?????
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 13389
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jul 2015 at 12:25pm
Originally posted by Mukus Mukus wrote:

Hi guys. First time pleas forgive me about my English language skill.

So. I have Nissan primera 2.2 dci and now I got problem.
I'm not sure about the parts name is right or no. From the inlet manifold come rubber hose to the turbo pipe and this hose has split. Is a very short pipe on both end have different size.. I couldn't find on ebay or in the scrap yard. Do you know where can I find. or just I searching with wrong name.....

Thanks for help.

Sincerely Mukus
Hi and welcome to the forumHandshake

I recommend you download the free electronic service manual following the link below

you will clearly be able to identify the part from here.
page EM 146 or EM 230 depending on which manual you download
 
you can then try
then many of the parts motor factors, other than that you are going to have to wait and be patient for the part to appear at he scrap yard or on ebay
Back to Top
 Post Reply Post Reply Page  12>

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2018 Nissan Primera Owners Club. All rights reserved.