Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P12 engine misfires.
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera P12 engine misfires.

 Post Reply Post Reply
Author
Message
tsakimak View Drop Down
NPOC Guest
NPOC Guest


Joined: 07 Jun 2010
Location: greece
Online Status: Offline
Points: 87
Post Options Post Options   Thanks (0) Thanks(0)   Quote tsakimak Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera P12 engine misfires.
    Posted: 08 Apr 2018 at 7:49pm
I posted before but probably it's been erased because of wrong to the rules subject.
I own a primera p12, have done a lot of work on it, I am thr guy who made the day for the ecu fix and saving a lot of people paying money to nissan. But now I am really angry, over a year I am trying to find out why the car from time to time misfires, it doesn't happen all the time, it could happen if I drive normally one time in a week it could happen if I drive from 140-160km per hour.Yesterday engine light came on and blinking while I was driving at 150km per hour, Car lost power for 15 sec and after that engine light gone off and never happened again. This happened again, the garage couldn't find what happened because the fault wasn't stored.
This thing will drive me nuts have changed maf, and crancksaft and camshaft sensors original ones, Spark plugs are new ngk, what could it be,? How can I check the coils if they are good as long as this happens for a while?
Have grounded all the car straight to the battery, and have both tail lights ground fixed.

This could be the time chain? How to check?
The car is petrol 1.6 liters and has 134000km manual gearbox.
Any help would be appreciated as I already put the car for sale , but I want to keep it because I have done a Lot of work on it.
Back to Top
tsakimak View Drop Down
NPOC Guest
NPOC Guest


Joined: 07 Jun 2010
Location: greece
Online Status: Offline
Points: 87
Post Options Post Options   Thanks (0) Thanks(0)   Quote tsakimak Quote  Post ReplyReply Direct Link To This Post Posted: 08 Apr 2018 at 7:53pm
I also tried to enter the diagnostics with the throttle pedal and the engine light blinks four times x ten blinks so it must be 0000,which is nothing as I guess
Back to Top
tsakimak View Drop Down
NPOC Guest
NPOC Guest


Joined: 07 Jun 2010
Location: greece
Online Status: Offline
Points: 87
Post Options Post Options   Thanks (0) Thanks(0)   Quote tsakimak Quote  Post ReplyReply Direct Link To This Post Posted: 10 Apr 2018 at 10:48am
guys nobody had similar issues?Propably i am cursed

Back to Top
roy.2 View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar

Joined: 23 Jan 2010
Location: Nr Bourne Lincs
Online Status: Offline
Points: 3071
Post Options Post Options   Thanks (0) Thanks(0)   Quote roy.2 Quote  Post ReplyReply Direct Link To This Post Posted: 10 Apr 2018 at 1:56pm
Hi. If you have changed the camshaft and crankshaft sensors its looking like a stretched chain. Ouch
Check the chain tensioner to see if it is sticking out more than 10mm. Thumbs Up
Roy
Back to Top
tsakimak View Drop Down
NPOC Guest
NPOC Guest


Joined: 07 Jun 2010
Location: greece
Online Status: Offline
Points: 87
Post Options Post Options   Thanks (0) Thanks(0)   Quote tsakimak Quote  Post ReplyReply Direct Link To This Post Posted: 14 Apr 2018 at 7:37am
thank you for the reply,i sold the car already just informed the new owner,have had enough of fixing it all the time,for me as a japan cars lover never had before a jap car that every month will need something to fix.Best regards
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2018 Nissan Primera Owners Club. All rights reserved.