Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P12 Heater problems...
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera P12 Heater problems...

 Post Reply Post Reply Page  <1 789
Author
Message
Cribber View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 18 Apr 2016
Location: Ipswich
Online Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Cribber Quote  Post ReplyReply Direct Link To This Post Posted: 18 Apr 2016 at 1:11pm
hi guys, I'm new to the forum and maybe late to the party but hope not. I have a 52 plate p12 where the blowers stopped working, I can adjust the speeds on my control unit but no output from the fan. I tried to do some basic fault finding before I found this forum. I found the 2 blower fuses to be fine and still making circuit but have to supply voltage to the blower itself. do you think that it could be the module by the clutch pedal? as mentioned above
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 13056
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 18 Apr 2016 at 6:01pm
I think it will be pretty certain the fan control unit would have failed so give it a go. Have you checked the state of the pollen filter, lack of maintenance has been highlighted as stressing the unit.
Back to Top
Cribber View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 18 Apr 2016
Location: Ipswich
Online Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Cribber Quote  Post ReplyReply Direct Link To This Post Posted: 19 Apr 2016 at 10:27am
Thanks for the reply. I did do alittle more investigating last night with some more reliable test equipment. It appears that I do have a supply to the fan, so is it likely to be a fan problem it is free and not siezed. I tried to take it out removed lots of screws but it still wouldn't come. Any ideas on how to get it out or what tests I could do on it to test it out. A friend of mine suggest connecting 12v straight to it to see if it runs to rule out any of the control circuits. Good idea yes or no?
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 13056
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 19 Apr 2016 at 4:21pm
I have not really seen any problems with the blower on here, would not like to comment on putting an un-fused voltage/current across the blower
Back to Top
timothycat View Drop Down
NPOC Guest
NPOC Guest


Joined: 09 Feb 2010
Location: milton keynes
Online Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote timothycat Quote  Post ReplyReply Direct Link To This Post Posted: 08 Oct 2017 at 10:23am
I cant find the resistor by the clutch pedal do you have any photos
steve
Back to Top
imckay View Drop Down
NPOC Guest
NPOC Guest


Joined: 11 Mar 2007
Location: Manchester
Online Status: Offline
Points: 3082
Post Options Post Options   Thanks (0) Thanks(0)   Quote imckay Quote  Post ReplyReply Direct Link To This Post Posted: 08 Oct 2017 at 10:43am
Welcome to NPOC,

http://www.npoc.co.uk/forum/p12-fan-speed-control-module-diy-repair_topic12795.html

If you get Photobucket errors, this can be fixed with a Chrome Plugin
Google 'photobucket embed fix'

Photobucket now charge users $400 to let their Pics appear on Forums.
Unsurprisingly, most people haven't paid.
Back to Top
 Post Reply Post Reply Page  <1 789

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2017 Nissan Primera Owners Club. All rights reserved.