Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P12, Loss of Power, help wtd.
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Click HERE to check out the latest awesome Club Video, courtesy of NPOC Member edk_N16 - Thanks Ed!


Nissan Primera P12, Loss of Power, help wtd.

 Post Reply Post Reply Page  12>
Author
Message
andy1494 View Drop Down
NPOC Guest
NPOC Guest


Joined: 28 Nov 2010
Online Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote andy1494 Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera P12, Loss of Power, help wtd.
    Posted: 28 Nov 2010 at 9:41am

hi there i have a p12 nissan primera 52 reg car, what i am asking for help, over the last few weeks i have had the engine stuttering and to seams like there no power to the engine, which has cause the engine warning light to flash and sometimes it has stayed on, but it not happening all the time, i first when it stayed on to it to my local nissan dealer who put a test on saying the following.

carry out consult check, engine spluttering and eng man light on, carried out diagonstic check reveals : PO171 erased fault code and reset learn and idle, air volume customer to try the vehicle, of which i did and again that afternoon started again spke to them they told me to book it in which i did.

they replaced the plugs rechecked system for DTC No DTC in system but catalyst srt not complete could be cat fault or just not being on long run. am no expert spoken to a few friends one say it could be the cat ot the lamber section not sure what that is, not spoken with the garage but i am still getting the same problem not all the time when the engine seams to have no power can some one help me with some ideas please  

Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 10127
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 28 Nov 2010 at 10:49am

Ah your 2nd post we were expecting, hope you are enjoying the P12 apart from this episode of course.

 
It sounds like one of the the MAF's (Mass Air flow Sensors) one on the air filter housing the other on the exhaust side. With care and gentle treatment they can be cleaned and allowed to dry with carb cleaner. They are delicate so don't hold the spray to close (10 2) the aim is to allow the cleaner onto the film to do its work not blast the thing clean. You will need a security torx to get it off. If that does not work the faulty one will have to be replaced. I believe they are interchangeable. but you ought to check, they are not cheap either.
Back to Top
andy1494 View Drop Down
NPOC Guest
NPOC Guest


Joined: 28 Nov 2010
Online Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote andy1494 Quote  Post ReplyReply Direct Link To This Post Posted: 28 Nov 2010 at 2:20pm
thanks for that will have a look at it tomorrow going to get a cat test in the morning as well as to check my windows as the broke today as well
Back to Top
vince776 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 09 Feb 2010
Location: Tyne and Wear
Online Status: Offline
Points: 45
Post Options Post Options   Thanks (0) Thanks(0)   Quote vince776 Quote  Post ReplyReply Direct Link To This Post Posted: 28 Nov 2010 at 2:30pm
yes defo sounds like MAF problem, as for the windows, they don't like the ice. If they are stuck and you try to open them, there is a small clip which breaks. This can be replaced but often the cables come away at the same time so the whole motor unit may need replaced!!!
Back to Top
andy1494 View Drop Down
NPOC Guest
NPOC Guest


Joined: 28 Nov 2010
Online Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote andy1494 Quote  Post ReplyReply Direct Link To This Post Posted: 28 Nov 2010 at 5:04pm
i no just my look at the moment will look at the maf in the morning
Back to Top
andy1494 View Drop Down
NPOC Guest
NPOC Guest


Joined: 28 Nov 2010
Online Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote andy1494 Quote  Post ReplyReply Direct Link To This Post Posted: 01 Dec 2010 at 12:25pm
replaced the MAF yesterday seams to be going ok just need to fix my window now tks for the help and advise
Back to Top
andy1494 View Drop Down
NPOC Guest
NPOC Guest


Joined: 28 Nov 2010
Online Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote andy1494 Quote  Post ReplyReply Direct Link To This Post Posted: 02 Dec 2010 at 7:32am
any more ideas this morning it started to stutter again again with the eng man light back on please
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 10127
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 02 Dec 2010 at 10:42am
Well There are two mafs on the p12 which  believe are interchangeable, So the one you took off must be working, I assume the one you put on is working so swap the one on the exhaust side with the one you took off and see what happensThumbs Up
Back to Top
andy1494 View Drop Down
NPOC Guest
NPOC Guest


Joined: 28 Nov 2010
Online Status: Offline
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote andy1494 Quote  Post ReplyReply Direct Link To This Post Posted: 02 Dec 2010 at 2:37pm
hi there timeshock is there a diagram as i can not see another one in the engine compartment tks
Back to Top
ragt20 View Drop Down
Admin Group
Admin Group

Swiss Tony

Joined: 02 May 2003
Location: Other
Online Status: Offline
Points: 67003
Post Options Post Options   Thanks (0) Thanks(0)   Quote ragt20 Quote  Post ReplyReply Direct Link To This Post Posted: 02 Dec 2010 at 8:59pm
Originally posted by timeshock! timeshock! wrote:

Well There are two mafs on the p12 which  believe are interchangeable, So the one you took off must be working, I assume the one you put on is working so swap the one on the exhaust side with the one you took off and see what happensThumbs Up
 
 
two mafs? you sure you don't mean O2 sensors...odd that having a maf on the exhaust side of things..Confused
FAO : Laurens, I am not Shaun.

Back to Top
 Post Reply Post Reply Page  12>

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2014 Nissan Primera Owners Club. All rights reserved.