Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P12 Radio Fault
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera P12 Radio Fault

 Post Reply Post Reply Page  12>
Author
Message
Nissan proud View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 07 Jun 2018
Location: east Rudham nfk
Online Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote Nissan proud Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera P12 Radio Fault
    Posted: 10 Jun 2018 at 12:24pm
Morning Members, I am hoping for advise on a problem with my P12 2-2 Dci T-Spec hatchback 2003,
 The radio when ignition is switched on occasionally does not work or radio is on but no controls work[volume, station, band,] on left side of console, it seems to freeze. This has been happening for about 2mths, its ok for a few days then freezes or will not work, have found that repeatedly pressing buttons/switches it works or turning ignition of then on it works. Sometimes Secure with green background appears on screen, operation of Sat/NAV effected at times as well. Heater, Demister, AC,[R/Hand of console] are not affected. When radio/Sat Nav are working they all work as normal, thought it might be a temperature thing as 1st did it when very cold earlier in year but no,
  If this helpful have owned car for 6+years 124k FSH last service Jan[local independent garage]. Have got them to look at it but sod's law been ok both times I left it with them, any advise would very much be appreciated thanks.
Back to Top
Estyfort View Drop Down
NPOC Guest
NPOC Guest


Joined: 16 Nov 2017
Location: Lagos, Nigeria
Online Status: Offline
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote Estyfort Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jun 2018 at 4:54pm
Have your keys reprogrammed. If this does not solve the problem, then your audio unit is faulty.
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 13527
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jun 2018 at 5:12pm
That is quite a range of symptoms which describe a multitude of possible problems.
1st thing to check starting off simple, when these symptoms started had you changed any bulb? are all bulbs working, any that you changed check they are exactly like for like, any not working replace. -if this is the case has it resolved the problem.
 
If not the case it may be worth doing the earth fix:

http://www.npoc.co.uk/forum/p12-rear-light-removal-now-with-simple-earth-fix_topic16533.html

While I doubt this next one is the issue without more serious starting issues it may be worth checking the main battery earth leads,

Check the battery earth leads to the chassis and transmission, making sure the are not broken and have good connection.

The green secure message usually means one of two issues, the AV unit is failing/failed or there is a communication issue with it and the IMMU part of the NATS. Fortunately this is also simple, you need to remove the bottom cowl of the steering wheel to give you access to the ignition barrel. Wrapped around the ignition barrel held in place by on small screw is a steel ring, this is the NATs antennae, remove this clean up and get rid of dirt and fluff build up and put everything back together again.

Next, do you have any issue with the display screen going black? the issue you describe in the cold matches failure of the circuit board on the DVD player for the sat Nav .

http://www.npoc.co.uk/forum/p12-blank-console-screen-repair_topic32396.html

Finally but by no means the last thing to try depending on your answer, could any of this be linked to when you turn the steering wheel?, if so it may be the beginning of the failure of the wiring loom to the steering wheel controls.

Back to Top
Nissan proud View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 07 Jun 2018
Location: east Rudham nfk
Online Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote Nissan proud Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jun 2018 at 9:15pm
hi Timeshock, thanks for your reply,
1, yes there is one bulb out on o/s/rear tail light, think there are three bulbs in a circle[1 out].
2, have looked at rear light fix, do that or change bulb first ?[will try bulb]
3, have look at Nats antennae,
4,no haven't had this issue[yet] will monitor this.
5 no this is not linked to steering being used.
Will do above list in that order and report on progress, might be a little while as work beckon's tmw 
[4-00] so if get chance in week will investigate, 
 Must say these elec probs unknown to me until I found this forum, as I have had car 6+yr 60k mls not had elec issue except had heater resistor fail. Thanks again Timeshock/
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 13527
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jun 2018 at 9:21pm
My Primera finally succumbed to the earth fix at a140k+
Back to Top
Nissan proud View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 07 Jun 2018
Location: east Rudham nfk
Online Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote Nissan proud Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jun 2018 at 9:42pm
You mean the rear light earth fix ?
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 13527
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 10 Jun 2018 at 9:42pm

yes

Back to Top
roystonvasey69 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 06 Sep 2008
Location: Yorkshire (East)
Online Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote roystonvasey69 Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jun 2018 at 12:18pm
I'd highly recommend doing the rear light earth mod regardless. Won't fix all the issues you highlight, but it certainly helped with a number of little niggles I was having (cruise self cancelling, intermittent loss of power on cornering etc). It's a happier car all round since I did this simple little job.
Hope you get sorted. Thumbs Up
Back to Top
Nissan proud View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 07 Jun 2018
Location: east Rudham nfk
Online Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote Nissan proud Quote  Post ReplyReply Direct Link To This Post Posted: 16 Jun 2018 at 10:21am
Hi everyone, have tried the rear light earth fix on both rear lights & replaced bulbs all lights now working but still radio issue.
 Would like to ask 'timeshock!' about NATS Anttennae fix, the two screws on the bottom column trim[nearest steering wheel] seem to have a plastic or some other covering preventing use of screwdriver, is this removable to gain access to screws or is there another way to gain access, thanks
Back to Top
Estyfort View Drop Down
NPOC Guest
NPOC Guest


Joined: 16 Nov 2017
Location: Lagos, Nigeria
Online Status: Offline
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote Estyfort Quote  Post ReplyReply Direct Link To This Post Posted: 16 Jun 2018 at 10:47am
I'd suggest you have the car scanned (Btw, is the CEL on?). The NATS antenna is not the IMMU it's the Smart Entrance Control unit. If the antenna is not transmitting signals properly, then it's going bad. I don't think dirt has much to play here.
Back to Top
 Post Reply Post Reply Page  12>

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2018 Nissan Primera Owners Club. All rights reserved.