Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P12 Screen Console Sat Nav Probs
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera P12 Screen Console Sat Nav Probs

 Post Reply Post Reply Page  123 81>
Author
Message
popswoo View Drop Down
NPOC Guest
NPOC Guest


Joined: 10 Apr 2008
Online Status: Offline
Points: 337
Post Options Post Options   Thanks (0) Thanks(0)   Quote popswoo Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera P12 Screen Console Sat Nav Probs
    Posted: 10 Apr 2008 at 2:23pm
Nissan Primera P12 - Console / Screen / Sat Nav / Camera / Broken / Dead / Blank / No Display. WE HAVE THE FREE FIX HERE!
 
Hi all.
I have a Nissan Primera SVE  TD  2002 and the screen does not display anything although there appears to be power to the screen when i turn on the ignition ie it changes colour.I dont have climate control - radio - cd dvd phone or any of the switches on the console working except for the switch which operates the windscreen demist and the green light on the switch comes on.
Please help.
Regards
Popswoo
 
===========================================
** Note from the NPOC Staff Team / Club Owners **
 
Our members here at NPOC took 10 months working together to find the problems here and yes, collectively they found the fixClap
 
If you want to see how you can fix it, go straight to page 28 of this thread and read from there onwards.
 
Or you can go find just 1 page of information where it's covered, on another UK Primera Forum. The owner of that forum, had no input in this thread here and simply waited for the result to be found on NPOC, because him and his forum are thieving, lazy fookers. 10 months of our members working it out, 10 minutes for him to steal the information and put it up in lights on his forum and take credit! 
===========================================
 

Safety / Disclaimer!!

The content found within this thread has been created by NPOC's members, some of them may be very competent mechanics, some of them may not.

You undertake or follow any of advice in this thread, entirely at your own risk.

The Owners or Staff Team of NPOC will NOT be held responsible, for any damage to either yourself, your vehicle or other road users as a result of you following information gathered from this thread.

If you do not have the tecnical ability, confidence or understanding of what you are doing, DO NOT DO IT!
 

You undertake or follow any of advice in this thread, entirely at your own risk.

Back to Top
catalistt View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 09 Oct 2007
Online Status: Offline
Points: 139
Post Options Post Options   Thanks (0) Thanks(0)   Quote catalistt Quote  Post ReplyReply Direct Link To This Post Posted: 10 Apr 2008 at 2:26pm
try disconecting and re conecting the battery somtimes it fails to boot up properly and doing this somtimes helps to clear it
Back to Top
popswoo View Drop Down
NPOC Guest
NPOC Guest


Joined: 10 Apr 2008
Online Status: Offline
Points: 337
Post Options Post Options   Thanks (0) Thanks(0)   Quote popswoo Quote  Post ReplyReply Direct Link To This Post Posted: 10 Apr 2008 at 2:59pm
Hi.
Tried disconnecting battery still not working.
Thanks for your help it seems strange that only the demister switch works on the console.
Regards
 
Popswoo
Back to Top
renrut View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 20 May 2007
Location: St Helens
Online Status: Offline
Points: 2201
Post Options Post Options   Thanks (0) Thanks(0)   Quote renrut Quote  Post ReplyReply Direct Link To This Post Posted: 10 Apr 2008 at 3:14pm
Assuming nothing is working and it's not just the display been switched off in the settings menu, it sounds like a bad connection in the centre console, probably a plug has fallen out, which they do if not put in right in the first place.

If you don't mind getting your hands dirty you could check the connections behind the keypad. You need to lift the centre console out to do this. Not particularly difficult but takes quite a bit of time.
Back to Top
popswoo View Drop Down
NPOC Guest
NPOC Guest


Joined: 10 Apr 2008
Online Status: Offline
Points: 337
Post Options Post Options   Thanks (0) Thanks(0)   Quote popswoo Quote  Post ReplyReply Direct Link To This Post Posted: 10 Apr 2008 at 3:36pm
Hi.
Thanks for the info.
Do you mean  remove the complete console or does the keypad come out separately ?
Is there a relay for this console ?
Regards
Popswoo
Back to Top
popswoo View Drop Down
NPOC Guest
NPOC Guest


Joined: 10 Apr 2008
Online Status: Offline
Points: 337
Post Options Post Options   Thanks (0) Thanks(0)   Quote popswoo Quote  Post ReplyReply Direct Link To This Post Posted: 10 Apr 2008 at 6:02pm
Hi Renrut.
Went to Halfords to buy a manual But they dont do one for my car.However on the way back my screen and everything on the console stated working but the sound was very crackly so it looks like your diagnosis was spot on for a bad connection.Will check connections tomorrow.
Well done & thank you for your help.
Will keep you informed.
Regards
Popswoo
Back to Top
essNchill View Drop Down
Admin Group
Admin Group
Avatar
Nissyen Gaius Fluff

Joined: 05 Feb 2003
Location: Hampshire
Online Status: Offline
Points: 61907
Post Options Post Options   Thanks (0) Thanks(0)   Quote essNchill Quote  Post ReplyReply Direct Link To This Post Posted: 10 Apr 2008 at 10:53pm
Hi Popswoo and a big welcome to the Nissan Primera Owners Club.
 
I know sod all about the P12 Primera (P10 / P11 owner) sadly but I do know that if you'd used a better description in your thread title, you'll grab the right audience and hopefully the right help.
 
I have edited your thread title from "primera" to "P12 - Console Screen Probs"Smile
 
It will help you, so please bear that in mind for furture threads.
 
Enjoy the forums and take care,
Shaun
Back to Top
renrut View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 20 May 2007
Location: St Helens
Online Status: Offline
Points: 2201
Post Options Post Options   Thanks (0) Thanks(0)   Quote renrut Quote  Post ReplyReply Direct Link To This Post Posted: 11 Apr 2008 at 8:30am
Theres a set of instructions in the tech section on how to pull apart the centre console (written by yours truly), it's a big scary mass of wires behind there but this simply sounds like one of the connectors to either the back of the keypad or one on the back of the audio unit has come loose. To get into the console you start by pulling out the gearlever surround and things kind of follow from there.
Back to Top
popswoo View Drop Down
NPOC Guest
NPOC Guest


Joined: 10 Apr 2008
Online Status: Offline
Points: 337
Post Options Post Options   Thanks (0) Thanks(0)   Quote popswoo Quote  Post ReplyReply Direct Link To This Post Posted: 11 Apr 2008 at 8:55am
Hi Renrut.
Thanks for the info.
I have tried to access the tec forum but get a message access denied.
Regards
Popswoo
Back to Top
ralprim View Drop Down
NPOC Guest
NPOC Guest


Joined: 04 Apr 2008
Online Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote ralprim Quote  Post ReplyReply Direct Link To This Post Posted: 11 Apr 2008 at 4:05pm
Hi, popswoo! I have practically the same problem with my 2002 P12 and since I am registered user I have posted my request for help in the technical section of the forum - still no info about the possible reason but most probably it is a loose connection as you already discussed above. If there is something new I'll post it here.
Ralie
Back to Top
 Post Reply Post Reply Page  123 81>

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2018 Nissan Primera Owners Club. All rights reserved.