Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P11 rear window washer
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera P11 rear window washer

 Post Reply Post Reply Page  12>
Author
Message
xpower View Drop Down
NPOC Guest
NPOC Guest


Joined: 12 Jul 2009
Online Status: Offline
Points: 24
Post Options Post Options   Thanks (0) Thanks(0)   Quote xpower Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera P11 rear window washer
    Posted: 06 Feb 2010 at 9:01pm

When activating the rear wash wipe there isn't any water coming out of the jets. The front jets work fine. I can hear the motor running and the water is moving down in the washer bottle as if there is pressure then returning to its previous level when the motor stops running.

I've taken a pin to the washer jets and they are not blocked.

Has anyone got suggestions how to solve this problem?

1996 Primera P11 2.0 SE manual
Back to Top
prim-n-proper View Drop Down
NPOC Guest
NPOC Guest
Avatar
Tick Tock Tick

Joined: 28 May 2007
Location: oop north
Online Status: Offline
Points: 18738
Post Options Post Options   Thanks (0) Thanks(0)   Quote prim-n-proper Quote  Post ReplyReply Direct Link To This Post Posted: 06 Feb 2010 at 9:07pm
easy one ....... buy a saloon, they ain't (in most cases ) got a rear wash wipe LOL
 
but seriously .... usually it's a build up of crap behind the jet, take the pipe off the rear jet and try the washer to clear it.
COTM: MAY 2006 P11 GT
COTM: MAY 2009 P11 SLX+
COTM: AUG 2012 P11 WAGON
LAST EVER COTM: NOV 2013 P10 eGT

Your "other car" might be newer, but it don't make it better than a P chassis.*PNP17*


Back to Top
Blue View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar
Sick End

Joined: 24 Mar 2006
Location: Swansea
Online Status: Offline
Points: 18282
Post Options Post Options   Thanks (0) Thanks(0)   Quote Blue Quote  Post ReplyReply Direct Link To This Post Posted: 06 Feb 2010 at 9:07pm
I had an issue with the front ones on my old 1.6 P11. I took the actual nozzle off and ended up soaking it in hot water for a few mins. Nothing ever came out that I could see but it seemed to fix the problem. This was after poking it with a pin, which didn't solve it, of course.
Not sure if that might help. If you can get the nozzle off and try the wiper, at least you should be able to see if any water comes out.
 
Sorted your thread title out as well btwThumbs Up
Back to Top
xpower View Drop Down
NPOC Guest
NPOC Guest


Joined: 12 Jul 2009
Online Status: Offline
Points: 24
Post Options Post Options   Thanks (0) Thanks(0)   Quote xpower Quote  Post ReplyReply Direct Link To This Post Posted: 06 Feb 2010 at 9:13pm

Thankyou both for the quick reponse. I'll will do that I hope it will be that easy to sort out.

Another thank you Blue for the the changing the thread title. Fingers working faster than the brain as usual. Embarrassed

1996 Primera P11 2.0 SE manual
Back to Top
xpower View Drop Down
NPOC Guest
NPOC Guest


Joined: 12 Jul 2009
Online Status: Offline
Points: 24
Post Options Post Options   Thanks (0) Thanks(0)   Quote xpower Quote  Post ReplyReply Direct Link To This Post Posted: 07 Feb 2010 at 12:14pm
 Do I have to remove this fascia to remove the nozzle:-
 
 
 Or can it just be detached from the outside?
1996 Primera P11 2.0 SE manual
Back to Top
imckay View Drop Down
NPOC Member
NPOC Member


Joined: 11 Mar 2007
Location: Manchester
Online Status: Offline
Points: 3270
Post Options Post Options   Thanks (0) Thanks(0)   Quote imckay Quote  Post ReplyReply Direct Link To This Post Posted: 07 Feb 2010 at 12:58pm
The pipe is quite tight I seem to remember.
I think you need to remove the cover from the high level brake light to remove the right hand cover.
 
Check the non-return valve is working. It is just down from the nozzle. Normally they leak but worth a check while you are in there.
Mine was leaking. Getting to it was easy, I just can't remember the exact details.
 
I cleared a nozzle on another car by blowing/sucking water through it.
Back to Top
xpower View Drop Down
NPOC Guest
NPOC Guest


Joined: 12 Jul 2009
Online Status: Offline
Points: 24
Post Options Post Options   Thanks (0) Thanks(0)   Quote xpower Quote  Post ReplyReply Direct Link To This Post Posted: 07 Feb 2010 at 1:03pm
Thank you for your help imckay.
1996 Primera P11 2.0 SE manual
Back to Top
Justin Thyme View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 01 Nov 2019
Location: Cheshire
Online Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote Justin Thyme Quote  Post ReplyReply Direct Link To This Post Posted: 03 Nov 2019 at 1:30am
I'm having the same issue with the rear washer on my P11 1998 Sri, i have no water travelling up the pipe, having taken the pipe off the nozzle.

I have an air line and compressor which solved both of the front sets of nozzles which was also ropey to say the least.

I've searched the site for a few details, does the P11 have a dual pump or two individual ones to power the front and rear, once i know where the pump is for the rear, that might help me solve the issue.
98 Primera Sri, Citroen Relay Van, collection of bikes and a Delta Evoluzione
Back to Top
patstonuk View Drop Down
NPOC Guest
NPOC Guest


Joined: 27 Jul 2009
Online Status: Offline
Points: 14
Post Options Post Options   Thanks (0) Thanks(0)   Quote patstonuk Quote  Post ReplyReply Direct Link To This Post Posted: 03 Nov 2019 at 1:38pm
I had a similar problem on an old P11 (now running a P12!) and a blocked non-return valve also generated a leak as fluid forced its way out of the join between the pipe and the valve. It was easy enough to get to, and was replaced with a valve off a scrapped Micra. It worked fine after that.
Back to Top
roy.2 View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar

Joined: 23 Jan 2010
Location: Nr Bourne Lincs
Online Status: Offline
Points: 3449
Post Options Post Options   Thanks (0) Thanks(0)   Quote roy.2 Quote  Post ReplyReply Direct Link To This Post Posted: 03 Nov 2019 at 4:05pm
Justin, you have to push the wiper stalk AWAY from you to get water to the rear screen. Pulling it toward you will only do the front. Thumbs Up
Roy
Back to Top
 Post Reply Post Reply Page  12>

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2019 Nissan Primera Owners Club. All rights reserved.