Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P11-144 Wipers not working!
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera P11-144 Wipers not working!

 Post Reply Post Reply
Author
Message
breadbin View Drop Down
NPOC Guest
NPOC Guest


Joined: 07 Feb 2009
Online Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote breadbin Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera P11-144 Wipers not working!
    Posted: 05 Apr 2010 at 12:30am
its the drivers side and it feels just loose, like there's no resistance at all if i twist it by hand. the passenger one seems to be ok although i haven't tried it since it was bashing into the drivers one. all i need now and what a night for it to happen on too absolutely pissing down:( is it hard to replace? costly? or could it be a fuse or something?i'm only guessing its the motor;)
Back to Top
imckay View Drop Down
NPOC Member
NPOC Member


Joined: 11 Mar 2007
Location: Manchester
Online Status: Offline
Points: 3271
Post Options Post Options   Thanks (0) Thanks(0)   Quote imckay Quote  Post ReplyReply Direct Link To This Post Posted: 05 Apr 2010 at 12:40am
There is a shaft from the motor to the passenger wiper.
There is another shaft from passenger side to driver side.
The shaft has cups on each end that press onto ball joints. This will have fallen off.
The cups wear out. New shaft around £10 from Nissan.
 
Quite easy to replace. Just follow this to get access to the shaft http://www.npoc.co.uk/forum/p11-replacing-a-wiper-arm-spindle_topic3080.html
Back to Top
breadbin View Drop Down
NPOC Guest
NPOC Guest


Joined: 07 Feb 2009
Online Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote breadbin Quote  Post ReplyReply Direct Link To This Post Posted: 05 Apr 2010 at 1:16pm
thanks so muchTongue i can't get over how easy it was. and yes the shaft had just fallen off. i put it back on and hope it will last til i get the replacement shaft tomorrow or sometime:) thanks again and to think i ws gonna leave it in to the garage to get sorted:)
Back to Top
almerasaloon View Drop Down
NPOC Guest
NPOC Guest


Joined: 30 Aug 2009
Location: Northern Ireland
Online Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote almerasaloon Quote  Post ReplyReply Direct Link To This Post Posted: 06 Apr 2010 at 6:52pm
same thing happened on my 1996 almera a month ago. Used a self tapping screw to secure it in place.
Back to Top
breadbin View Drop Down
NPOC Guest
NPOC Guest


Joined: 07 Feb 2009
Online Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote breadbin Quote  Post ReplyReply Direct Link To This Post Posted: 07 Apr 2010 at 10:19pm
eh whats a self tapping screw?
Back to Top
neds View Drop Down
NPOC Guest
NPOC Guest


Joined: 23 Apr 2007
Online Status: Offline
Points: 96
Post Options Post Options   Thanks (0) Thanks(0)   Quote neds Quote  Post ReplyReply Direct Link To This Post Posted: 07 Apr 2010 at 10:42pm
Originally posted by breadbin breadbin wrote:

eh whats a self tapping screw?


Its a screw that will cut its own thread through thin sheet metal.
Back to Top
GaryeGT View Drop Down
NPOC Guest
NPOC Guest

Guinness Gaz

Joined: 30 Jun 2008
Location: Limerick
Online Status: Offline
Points: 11356
Post Options Post Options   Thanks (0) Thanks(0)   Quote GaryeGT Quote  Post ReplyReply Direct Link To This Post Posted: 07 Apr 2010 at 10:45pm
sounds like you need new spindles mate. my advise, and im sure nobody will disagree, get some spindles off a p10 as theyre a much better, stronger and reliable spindle. and theyre a direct fit tooWink

baffles me as to why nissan went downhill with parts with newer cars
Back to Top
jgduffin View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 06 Dec 2009
Location: Kent
Online Status: Offline
Points: 21
Post Options Post Options   Thanks (0) Thanks(0)   Quote jgduffin Quote  Post ReplyReply Direct Link To This Post Posted: 19 Oct 2019 at 1:07am
This has just happened on my P11-144, in the middle of the worst rain imaginable. Managed to drive home slowly by looking through the passenger side.

Glad I found this thread. I'll try the fix in the morning.

Not too bad though. First wiper fault I've had on the car (apart from the usual pausing on intermittent wipe, which ive got a replacement motor for) and shes just turned 20 years old, and only done 210,000 miles. Barely run in
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2019 Nissan Primera Owners Club. All rights reserved.