Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P12 2.0 Auto/various issues, help!
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera P12 2.0 Auto/various issues, help!

 Post Reply Post Reply
Author
Message
Danny356 View Drop Down
NPOC Guest
NPOC Guest


Joined: 27 Jun 2020
Online Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote Danny356 Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera P12 2.0 Auto/various issues, help!
    Posted: 27 Jun 2020 at 6:40am
Hi guys, first post sorry its a bunch of questions!

So mine is a 52 plate, P12, 2.0, Auto, T-Spec with 65k. Had it a year and love it but it has a few issues:

1. I get a violent jolting while on the throttle from time to time, where it feels like the brakes have been applied. Just for a second then it's fine. Seems to happen mainly when I'm cruising along rather than accelerating.

2. It stalls at slow speed manouvering. Not even when changing from D to reverse, just slowing down to do a 3 point turn, it'll sometimes stall.

3. The engine has a ticking sound that rises with the revs. Its a chattering, ticking sort of sound. It sounds a bit clapped out.

4. I usually cruise around, trying to save fuel, but If I use the revs at all when I stop there's a sort of burning smell from the engine bay.

5. It seems quite jerky getting off the line, the throttle seems very sensitive. You only need a tiny press on the accelerator and at first it seems slow to engage the gear, then it goes in and flies off. It took me a long while to learn to drive it smoothly, you have to use a tiny amount of throttle when starting off. Is that normal?

I've done the earth fix on the rear lights, but not on the engine yet. Any ideas much appreicated. I love the car but its clearly not happy right now!

Thanks in advance!



Back to Top
imckay View Drop Down
NPOC Member
NPOC Member


Joined: 11 Mar 2007
Location: Manchester
Online Status: Offline
Points: 3298
Post Options Post Options   Thanks (0) Thanks(0)   Quote imckay Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jun 2020 at 9:56am
Welcome to NPOC

2. Sounds like the MAF. I had the same symptom on the previous Model of Primera
On some Cars you can unplug the MAF to prove the fault. On mine it would not rev over 2K with it was unplugged.

The noise and other symptoms could possibly be a stretched chain but I didn't think this affected the 2.0 as much as it does the 1.8

I take it you don't have an Engine Light on?
Back to Top
patstonuk View Drop Down
NPOC Guest
NPOC Guest


Joined: 27 Jul 2009
Online Status: Offline
Points: 19
Post Options Post Options   Thanks (0) Thanks(0)   Quote patstonuk Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jun 2020 at 4:04pm
A few years ago my 2.0 P12 developed what I would describe as a light, chattering noise when under acceleration and on some occasions this was accompanied by the faintest whiff of exhaust. Investigation revealed it to be a slight blow-by at a lambda sensor.
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2020 Nissan Primera Owners Club. All rights reserved.