Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P12 Centre Console Problem
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera P12 Centre Console Problem

 Post Reply Post Reply Page  123>
Author
Message
pixie123 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 06 Oct 2012
Online Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote pixie123 Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera P12 Centre Console Problem
    Posted: 24 Nov 2012 at 9:29am
Hello,

I've got a problem with the centre console on my my P12 (2003) Primera. I've not used the car for a week or so, but when I got in it this morning the centre console lit up as usual but i could not get the radio to work or the heater. None of the buttons that i would press for info or heater control work either. All that did happen was that the heater/fan came on but slowly went off again, and i had no control over that.   

Does anyone have any idea what could have gone wrong, could it be a fuse?
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 13860
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 24 Nov 2012 at 10:20am
By any chance do you have sat nav fitted and is the screen working?
Back to Top
pixie123 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 06 Oct 2012
Online Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote pixie123 Quote  Post ReplyReply Direct Link To This Post Posted: 24 Nov 2012 at 10:22am
no I've no sat nav or phone etc, but the screen is working. It looks like it's just the controls that aren't doing anything
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 13860
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 24 Nov 2012 at 10:33am
OK so it is not as I initially thought it might be, sounds like a a fuse may take a little while for me to look up which one, all this info is in the free electronic service manual download from here if you are interested.
 
Back to Top
pixie123 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 06 Oct 2012
Online Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote pixie123 Quote  Post ReplyReply Direct Link To This Post Posted: 24 Nov 2012 at 10:36am
thanks for this, I'm not a technical person but I'll have a look and see if I can work it out. Where are the fuses for the console likely to be inside the car or under the bonnet?
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 13860
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 24 Nov 2012 at 10:42am
These fuse are goint to be near your left knee when you are in your driving position protected by a simple pull off plastic cover. try checking  and carefull inspecting fuses 2, 3 and 33.
 
I am suspecting though the connector plug known as M54 has fallen off the back of the unit it is not unkown to have happened
Back to Top
pixie123 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 06 Oct 2012
Online Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote pixie123 Quote  Post ReplyReply Direct Link To This Post Posted: 24 Nov 2012 at 10:57am
thanks again.

I downloaded the manual and it's all a bit confusing for me but I'll check the fuses as you said and fingers crossed it's one of them. In the unlikely event that it's the plug that's come our, is the M54 plug easy to put back in or will I need to take it to a garage?

I'll let you know how I get on though
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 13860
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 24 Nov 2012 at 10:59am
Also check fuse 10
 
You would need to take out part of the dash
Back to Top
imckay View Drop Down
NPOC Member
NPOC Member


Joined: 11 Mar 2007
Location: Manchester
Online Status: Offline
Points: 3275
Post Options Post Options   Thanks (0) Thanks(0)   Quote imckay Quote  Post ReplyReply Direct Link To This Post Posted: 24 Nov 2012 at 11:25am
As above fuse 10 is connected to both the radio and the heater controls.

Back to Top
pixie123 View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 06 Oct 2012
Online Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote pixie123 Quote  Post ReplyReply Direct Link To This Post Posted: 24 Nov 2012 at 7:46pm
well I've checked all the fuses and they all seem fine :( so it looks like the plug thing might have come out. I'm not sure if i could take out the 'dash' as it all seems to be tightly fit and there's no obvious catches or anything to get it out with, but I'll have a try tomorrow and see how it goes!

thanks again
Back to Top
 Post Reply Post Reply Page  123>

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2019 Nissan Primera Owners Club. All rights reserved.