Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P12 coolant problem
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera P12 coolant problem

 Post Reply Post Reply
Author
Message
Bohica View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 16 Jul 2018
Location: Grimsby
Online Status: Offline
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bohica Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera P12 coolant problem
    Posted: 25 Mar 2020 at 11:28am
Hi guys,

ok so the mechanic I took my P12 to said I had a leaky oil pressure sensor and showed me where it was, I ordered one, it arrived (without any washer or gasket) so today I tried to fit it. Can you imagen my surprise when I unscrewed it and coolant started gushing out of the hole?

I put it back in but now I know the cylinder head is empty of coolant, I have tried running the engine to get it to circulate but instead of the air coming out of the top of the radiator I get  coolant.

The air bleed nut on the pump is below where I suspect my coolant level is so I am loath to crack that.

My question is if I leave the engine idling for 10 mins or so will the air work its way round to the radiator and out so I can top it up again? Because as it stands the radiator is showing full (coolant visible when I remove the cap).

Advice?

Many thanks 

Paul K.  
I think therefor I am.
Back to Top
essNchill View Drop Down
Admin Group
Admin Group
Avatar
Nissyen Gaius Fluff

Joined: 05 Feb 2003
Location: Hampshire
Online Status: Offline
Points: 62125
Post Options Post Options   Thanks (0) Thanks(0)   Quote essNchill Quote  Post ReplyReply Direct Link To This Post Posted: 25 Mar 2020 at 12:01pm
What's the "oil pressure sensor" got to do with this? I'm confused.
Back to Top
Bohica View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 16 Jul 2018
Location: Grimsby
Online Status: Offline
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bohica Quote  Post ReplyReply Direct Link To This Post Posted: 25 Mar 2020 at 12:21pm
Thats what this "mechanic" said was at the front of the engine leaking the oil I could see, but as I said it turns out to be the water temp sensor, so not only did I buy the wrong thing its not even the system he told me it was. So now I also have a coolant problem to go with my oil problem..... you cant write this stuff lol

Paul K.
I think therefor I am.
Back to Top
essNchill View Drop Down
Admin Group
Admin Group
Avatar
Nissyen Gaius Fluff

Joined: 05 Feb 2003
Location: Hampshire
Online Status: Offline
Points: 62125
Post Options Post Options   Thanks (0) Thanks(0)   Quote essNchill Quote  Post ReplyReply Direct Link To This Post Posted: 25 Mar 2020 at 12:36pm
Right got you :) So you have both a leak from the OPS and also an issue with the WTS.
Back to Top
roy.2 View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar

Joined: 23 Jan 2010
Location: Nr Bourne Lincs
Online Status: Offline
Points: 3535
Post Options Post Options   Thanks (0) Thanks(0)   Quote roy.2 Quote  Post ReplyReply Direct Link To This Post Posted: 25 Mar 2020 at 1:24pm
Paul. Squeeze the bottom hose, that should send air to the top. Thumbs Up
Roy
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2020 Nissan Primera Owners Club. All rights reserved.