Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P12 engine noise when warm
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera P12 engine noise when warm

 Post Reply Post Reply
Author
Message
Darcen View Drop Down
NPOC Guest
NPOC Guest


Joined: 10 Nov 2019
Online Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote Darcen Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera P12 engine noise when warm
    Posted: 10 Nov 2019 at 1:53pm
Hey all.
As Im new to this forum I cant post in mechanical sub. So please dont be mad. Im pretty desperate and not trusting my autoshop much. I have 2006 Primera p12 with 2.0 103kw engine. Problem started with rattling noise coming from engine. Went to local autoshop and they changed timing chain. Got car back and similar sound when engine is warm. With cold enginge car ryns perfectly, no noise, anything. Only after like 10+ kilometers noise starts in about 1500rpm. Now carshop says oilpump needs to be changed maybe, because oil pressure is low 0,4bar idle and 1,9 at 2000rpm. Well location of oil pump is pretty damn stupid. Same procedure like changing timing chain. My main question is why everything is okay with cold engine. Has anyone gone throuh similar thing?
Back to Top
bavs83 View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 26 Dec 2008
Location: Lancashire
Online Status: Offline
Points: 816
Post Options Post Options   Thanks (0) Thanks(0)   Quote bavs83 Quote  Post ReplyReply Direct Link To This Post Posted: 10 Nov 2019 at 2:46pm
Did the garage change the chain tensioner at the same time they changed the chain?
It's not what you drive....It's how you drive!
Back to Top
Darcen View Drop Down
NPOC Guest
NPOC Guest


Joined: 10 Nov 2019
Online Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote Darcen Quote  Post ReplyReply Direct Link To This Post Posted: 10 Nov 2019 at 4:18pm
Yup, the whole set. At least thats what I payd for. I find it silly that they did not measure the oil pressure first time. Gave me car back sayd its okay now. After longer run I found out that the the noise is still there, not as bad it was but still.
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2019 Nissan Primera Owners Club. All rights reserved.