Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P12 jerking at 1500rpm
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera P12 jerking at 1500rpm

 Post Reply Post Reply
Author
Message
ACHABATA View Drop Down
NPOC Guest
NPOC Guest


Joined: 01 Jul 2019
Location: Harare
Online Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote ACHABATA Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera P12 jerking at 1500rpm
    Posted: 07 Aug 2019 at 8:15am
hi guys, I have confusing problem. my 2002 1.8ltr P12 hatchback manual is giving me a confusing problem, it just started jerking between 1500 and 2000rpm, when you press the accelerator to the floor it breathes heavily like its been choked from the air cleaner housing. usually it starts with the engine coolant gauge fluctuating up an down then the jerking starts. could it be the temperature gauge sensor causing all this?

thank you for helping
Back to Top
pianoprimera View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 29 Jun 2019
Location: Staffordshire
Online Status: Offline
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote pianoprimera Quote  Post ReplyReply Direct Link To This Post Posted: 07 Aug 2019 at 1:05pm
I cannot advise on the temp gauge sensor, but I myself would check the air filter (which you probably have). I'd get a can of electrical contact spray and clean the MAF sensor (not WD40! it has to be what I've described, and don't touch inside the MAF sensor). Whilst the MAF sensor is off I'd spray some WD (or the electrical contact spray) into the throttle housing, and wipe it out with a cloth wrapped around a couple of fingers. You'll feel a metal flap in there that could (?) be sticking. Check all the rubber piping for cracks and air leaks too.

Am sure more replies will follow that will be better than mine . . .
Back to Top
roy.2 View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar

Joined: 23 Jan 2010
Location: Nr Bourne Lincs
Online Status: Offline
Points: 3449
Post Options Post Options   Thanks (0) Thanks(0)   Quote roy.2 Quote  Post ReplyReply Direct Link To This Post Posted: 07 Aug 2019 at 8:35pm
Hi Allen.  Welcome to NPOC.  Handshake
Try the rear light Earth Fix.  Thumbs Up
Roy
Back to Top
imckay View Drop Down
NPOC Member
NPOC Member


Joined: 11 Mar 2007
Location: Manchester
Online Status: Offline
Points: 3270
Post Options Post Options   Thanks (0) Thanks(0)   Quote imckay Quote  Post ReplyReply Direct Link To This Post Posted: 08 Aug 2019 at 7:49am
Welcome to NPOC,

Worth trying the Rear Light Fix as Roy says

Insufficient Ground/Earth at the back of the Car causes odd electrical problems
Back to Top
ACHABATA View Drop Down
NPOC Guest
NPOC Guest


Joined: 01 Jul 2019
Location: Harare
Online Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote ACHABATA Quote  Post ReplyReply Direct Link To This Post Posted: 09 Aug 2019 at 7:26am
Hie guys 

Thank you so much for your prompt responses, well I did fix the earth on the rear light indeed it had a problem, the idling has since changed however am still experiencing a bit of jerking especially when the coolant temperature gauge falls to the floor. when the car jerks the gauge fluctuates simultaneously and the car wont accelerate properly until the gauge is steady. 
Back to Top
roy.2 View Drop Down
NPOC Elite Member
NPOC Elite Member
Avatar

Joined: 23 Jan 2010
Location: Nr Bourne Lincs
Online Status: Offline
Points: 3449
Post Options Post Options   Thanks (0) Thanks(0)   Quote roy.2 Quote  Post ReplyReply Direct Link To This Post Posted: 09 Aug 2019 at 9:11am
Did you do both sides?
Roy
Back to Top
BrianMccaul View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 12 May 2012
Location: Belfast
Online Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote BrianMccaul Quote  Post ReplyReply Direct Link To This Post Posted: 11 Aug 2019 at 2:06pm
I had the same problem and replaced the air filter and boom sorted.

Brian
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2019 Nissan Primera Owners Club. All rights reserved.