Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera P12 loosing power when idling
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera P12 loosing power when idling

 Post Reply Post Reply
Author
Message
platforminc View Drop Down
NPOC Guest
NPOC Guest


Joined: 07 Aug 2012
Online Status: Offline
Points: 12
Post Options Post Options   Thanks (0) Thanks(0)   Quote platforminc Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera P12 loosing power when idling
    Posted: 16 Sep 2020 at 12:31pm
Hi All.

I have a 2003 Primera P12, when the car starts and is left alone, after some few minutes/seconds it feels as though the car is about to cut out, the rev counter drops to below one briefly and then comes back up again.

This also happens when driving, especially when in traffic and if care is not taken, sometimes the car completely cuts out.

The car was serviced 3 months ago. spark plugs changed, oil etc.
I used a scanner to scan the car, no error codes, and I am unsure as to what the issue could be.



Back to Top
Echoesz View Drop Down
NPOC Guest
NPOC Guest
Avatar

Joined: 21 Apr 2019
Location: The Netherlands
Online Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote Echoesz Quote  Post ReplyReply Direct Link To This Post Posted: 21 Sep 2020 at 3:19pm
Hi there!

I had the same thing last month.
My problems were a faulty crankshaft sensor. Had it replaced and problems solved.

Good luck!

PS: The crankshaft and camshaft are exactly the same sensor.

Cheers!
Sander
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 14050
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 21 Sep 2020 at 6:23pm
You don't say which engine you have but i have gleaned it must be petrol if the the spark plugs have been changed. I take it your air filter also has been changed. Check you have nothing blocking the air flow to the filter intake, it has been known for a loose headlight cover to do this. I would also check you battery earth leads to the chassis and gear box ensuring good connection and no breaks.
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2020 Nissan Primera Owners Club. All rights reserved.