Nissan Primera Owners Club Nissan Primera Owners Club > General Open Forums - NO TRADING! > Nissan Primera Help & Queries
  New Posts New Posts RSS Feed - Nissan Primera (WP12) 2.0 2005 - RPM Problem
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Nissan Primera (WP12) 2.0 2005 - RPM Problem

 Post Reply Post Reply
Author
Message
TeddyBearJohn View Drop Down
NPOC Guest
NPOC Guest


Joined: 09 Apr 2021
Online Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote TeddyBearJohn Quote  Post ReplyReply Direct Link To This Post Topic: Nissan Primera (WP12) 2.0 2005 - RPM Problem
    Posted: 15 Apr 2021 at 7:08pm
Hello everyone!

I recently got my Primera and it was having high idle problems. I managed with the use of this forum do these procedures : 
Accelerator Pedal Released Position Learning
Throttle Valve Closed Position Learning
Idle Air Volume Learning

Which fixed the issue for me. Now i have a different problem. When standing still in P and i rev the engine the RPM goes up and then back down and then there is a slight jump up again and then it finally goes down and stays there.

I read somewhere here that it could do with a mechanism that tries to save fuel when above 40 mph. But this happens when standing still so i assumed it isn't that.

Does anyone have any idea of what the problem could be?

I have cleaned the Throttle Body and it seemed like the problem went away but then it was back the next day.

Thanks in advance!
Back to Top
timeshock! View Drop Down
NPOC Member
NPOC Member
Avatar

Joined: 29 Jan 2006
Location: Newcastle
Online Status: Offline
Points: 14190
Post Options Post Options   Thanks (0) Thanks(0)   Quote timeshock! Quote  Post ReplyReply Direct Link To This Post Posted: 16 Apr 2021 at 8:46am
Hi and welcome tot he forumHandshake

Not entirely sure I have seen this issue before, I take it you have taken a look at out service manual?

Have a look here as well


Back to Top
TeddyBearJohn View Drop Down
NPOC Guest
NPOC Guest


Joined: 09 Apr 2021
Online Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote TeddyBearJohn Quote  Post ReplyReply Direct Link To This Post Posted: 16 Apr 2021 at 2:36pm
Thanks!

I have taken a look at the service manual. I haven't gone through the whole thing yet though.

I haven't changed the transmission fluid. The level seemed okay when i checked it, but i didn't really check the color of it. Could it be bad transmission fluid?

Also I haven't done the Earth Fix. Could that solve the problem?

Also here is a link to a video showing the problem : 
https://drive.google.com/file/d/16M6WKf7tlHRvMP0SOblpPBy8mcreJv0f/view?usp=sharing

It doesn't jump up today, now it's more like it waits before going all the way down.

Back to Top
imckay View Drop Down
NPOC Member
NPOC Member


Joined: 11 Mar 2007
Location: Manchester
Online Status: Offline
Points: 3326
Post Options Post Options   Thanks (0) Thanks(0)   Quote imckay Quote  Post ReplyReply Direct Link To This Post Posted: 19 Apr 2021 at 7:29am
Welcome to NPOC

I think that is normal.
Pretty sure my previous Gen Petrol Manual Primera did the same.
Quick drop to 1500 and a slower drop to 750ish idle

I think it is the Idle Valve opening up fully when you are above certain rpm.
When you lift off the Accelerator, closing the Throttle, the Idle Valve lets enough Air in for 1500 rpm.
It then closes up to get from 1500 to idle.
Back to Top
TeddyBearJohn View Drop Down
NPOC Guest
NPOC Guest


Joined: 09 Apr 2021
Online Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote TeddyBearJohn Quote  Post ReplyReply Direct Link To This Post Posted: 19 Apr 2021 at 10:19pm
Thanks!

Oh okay!
I won't worry then Smile

Thanks for the help!
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

This forum is optimised for a 1024x768 screen resolution

Copyright © 2001-2020 Nissan Primera Owners Club. All rights reserved.